Issue displaying some previews in Pulumi Cloud

Incident Report for Pulumi

Resolved

The issue affecting previews in Pulumi Cloud has been resolved. Previews are functioning normally again. Please note that affected previews during the incident window (between 11pm UTC Sept 7, 2025 and 7pm UTC Sept 8, 2025) were not recoverable and will not be available in your history.
Posted Sep 08, 2025 - 12:21 PDT

Identified

We’ve identified the root cause of the preview display issues in Pulumi Cloud and are actively rolling out a fix. Thanks for your patience — we’ll share another update once the rollout is complete.
Posted Sep 08, 2025 - 11:00 PDT

Investigating

We are currently experiencing issues with displaying some previews in Pulumi Cloud. Our team is actively investigating the problem and working toward a resolution. We will provide updates as soon as more information is available.
Posted Sep 08, 2025 - 10:27 PDT
This incident affected: Console.